Subject: Re: Two little features (and a bounty?)

From: "Joe Zbiciak" <[email-masked]>
Date: Fri, 25 Jul 2008 01:06:55 -0500

This is the point of the conversation where I butt my head in and
look stupid.  :-)

----- Original Message ----
Micah Cowan wrote:
> >> Wait, where are you running screen?  My assumption was that you be
> >> running it ON prime.gushi.org, not before you ssh in.
>
> Right. I'm doing both.
>
> >> When I ssh from my mac to prime, nano -m works.
> >
> >> When I ssh from my mac to prime and start screen -q, nano -m doesn't.
>
> When you set TERM=xterm? (That was what we were talking about)
>
> Within screen running on gushi, "TERM=xterm nano -m" gives me mouse
> capabilities (but isn't a great idea long-term, as it may well screw up
> other things subtly).

Micah,

This may be a silly question, but how does "screen" decide that the
attaching terminal supports capturing mouse events?  It could be that
nano says it's interested, but screen thinks they're not available.

I'm no expert in the screen code base, but is this where?

  if (InStr(D_termname, "xterm") || InStr(D_termname, "rxvt"))
      D_CXT = 1;

Dan,

What do you have TERM set to when you launch screen?  If you say
"TERM=xterm screen" to start screen, does that change things?

Regards,

--Joe

-- 
We sell spatulas, and that's all!
http://spatula-city.org/~im14u2c/
http://spacepatrol.info/
_______________________________________________
screen-users mailing list
[email-masked]
http://lists.gnu.org/mailman/listinfo/screen-users

---

From: "Joe Zbiciak" <[email-masked]>
Date: Fri, 25 Jul 2008 01:09:34 -0500

>   if (InStr(D_termname, "xterm") || InStr(D_termname, "rxvt"))

I should add that I say this due to this code elsewhere:

void
MouseMode(mode)
int mode;
{
  if (display && D_mouse != mode)
    {
      char mousebuf[20];
      if (!D_CXT)
        return;
      if (D_mouse)
        {
          sprintf(mousebuf, "\033[?%dl", D_mouse);
          AddStr(mousebuf);
        }
      if (mode)
        {
          sprintf(mousebuf, "\033[?%dh", mode);
          AddStr(mousebuf);
        }
      D_mouse = mode;
    }
}

---

From: Micah Cowan <[email-masked]>
Date: Sat, 26 Jul 2008 10:53:56 -0700

>   if (InStr(D_termname, "xterm") || InStr(D_termname, "rxvt"))

Yes indeed.

- --
Micah J. Cowan
Programmer, musician, typesetting enthusiast, gamer,
and GNU Wget Project Maintainer.
http://micah.cowan.name/