Subject: sticky modifier keys

From: William Pursell <[email-masked]>
Date: Wed, 01 Oct 2008 20:05:18 +0100

I've recently started using sticky modifier keys
(eg, touch and release modifier, then hit a key to
get the modified key).  KDE can be configured
to do this, and I can use loadkeys on a console,
but I recently was stuck on a console where I
didn't have root and couldn't do loadkeys to
set the modifiers to be sticky.

Is there anyway to get this functionality with
screen?

-- 
William Pursell

_______________________________________________
screen-users mailing list
[email-masked]
http://lists.gnu.org/mailman/listinfo/screen-users

---

From: [email-masked] (Trent W. Buck)
Date: Thu, 02 Oct 2008 11:05:06 +1000

William Pursell <[email-masked]>
writes:

> I've recently started using sticky modifier keys [...]
> Is there anyway to get this functionality with screen?

I think it's impossible.  X11 clients can see keydown and keyup events
for the modifier key(s) and the non-mod key separately.  Screen just
sees a single event (a keydownup, essentially) of the entire
chord.

For example if you press Control_L and Alt_L, nothing is
sent to screen until you also press (say) f -- at which point Screen
sees the two chords ^[ ^F.

---

From: peter holm <[email-masked]>
Date: Sun, 05 Oct 2008 16:57:20 +0200

> Is there anyway to get this functionality with

May this be a solution to you.?

http://tsdh.wordpress.com/2007/04/12/sticky-keys-save-my-hands-from-rsi/
http://www.oesf.org/forum/index.php?s=1d9fce9ecb853fc3d777d11e63d8ee4c&showtopic=10404

I have just glanced the text, so please don't flame if it not suit your
needs.

/Peter