Subject: sending CRLF via screen -X stuff

From: "Richard Elliot" <[email-masked]>
Date: Mon, 10 Nov 2008 09:49:45 -0800

Hello,

I am trying to send a remote command to an existing screen session:

while true; do screen -S 19268 -X stuff "signon"; sleep 1m; done

However, I need to send a new line (CRLF) after the command "signon".

Any help would be greatly appreciated.

Thanks very much,

Richard
_______________________________________________
screen-users mailing list
[email-masked]
http://lists.gnu.org/mailman/listinfo/screen-users

---

From: Micah Cowan <[email-masked]>
Date: Mon, 10 Nov 2008 21:02:34 -0800

> However, I need to send a new line (CRLF) after the command "signon".

Chances are you only need one of CR or LF, not both. Anyway, use octal
escapes: \012 and \015. (And yeah, I'd like to see a more complete set
of C-style escapes make their way in; low pri though.)

- --
Micah J. Cowan
Programmer, musician, typesetting enthusiast, gamer.
GNU Maintainer: wget, screen, teseq
http://micah.cowan.name/

---

From: "Pandurangan R S" <[email-masked]>
Date: Tue, 11 Nov 2008 10:38:18 +0530

Here is what i use

screen -X eval 'stuff "echo abc\015"'

Regards
Pandu

On Mon, Nov 10, 2008 at 11:19 PM, Richard Elliot <[email-masked]
> wrote:

---

From: "Richard Elliot" <[email-masked]>
Date: Tue, 11 Nov 2008 04:59:27 -0800

Thanks for the help.

Would this be correct?

while true; do screen -S 19268 -X stuff "signon"\012; sleep 1m; done

On Mon, Nov 10, 2008 at 9:02 PM, Micah Cowan <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Richard Elliot wrote:
> > Hello,
> >
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
>
> iEYEARECAAYFAkkZEeoACgkQ7M8hyUobTrGP5gCeOhO6BuYb1vtr1O8IF0U4/jSE
> JlUAni/Yg5vT6GwgAk3xHpI7DHDFrrB3
> =m69U
> -----END PGP SIGNATURE-----
>