Subject: bug #23945

From: YONETANI Tomokazu <[email-masked]>
Date: Mon, 11 Aug 2008 20:38:47 +0900

Hi.
After the fix to #23945 (cb9d14bd8a198447d20ccd4be848df679a3047d9) committed,
the cursor temporarily displayed at the wrong place when I enter copy-mode
and move the cursor while "Copy mode - ..." caption is displayed.  The
cursor stays at the wrong place on the terminal until I refresh the screen
or select the top-left corner of the region.  It only happens when the
following conditions are met:
- the cursor is at the last line of the screen, without a status line
- the cursor is not at the beginning of the line

Anyone else seeing this?

Cheers.

_______________________________________________
screen-users mailing list
[email-masked]
http://lists.gnu.org/mailman/listinfo/screen-users

---

From: Micah Cowan <[email-masked]>
Date: Wed, 13 Aug 2008 12:35:56 -0700

> - the cursor is not at the beginning of the line

I do. If I hit "k" immediately upon entering copy-mode, the cursor moves
to the first column, but the copy behaves as if it's in its original column.

Thanks for the report! Issue filed at
https://savannah.gnu.org/bugs/index.php?24058

- --
Micah J. Cowan
Programmer, musician, typesetting enthusiast, gamer.
GNU Maintainer: wget, screen, teseq
http://micah.cowan.name/

---

From: YONETANI Tomokazu <[email-masked]>
Date: Thu, 21 Aug 2008 10:15:16 +0900

On Wed, Aug 13, 2008 at 12:35:56PM -0700, Micah Cowan wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> YONETANI Tomokazu wrote:
> > Hi.

Oh, thanks for filing it, and I confirmed it's been fixed now.

Cheers.