Subject: set window title from nested screen?

From: "Aaron Davies" <[email-masked]>
Date: Mon, 18 Aug 2008 09:59:17 +0800

i can set the window title from a single-level screen (echo -ne
'\e]2;foo^G'), but when i try from a second-level nested screen,
nothing happens.

i'm running putty-cyg on windows as my terminal, with cygwin zsh
running locally, running cygwin screen, ssh'ing into linux boxes,
running bash and screen remotely.
-- 
Aaron Davies
[email-masked]

_______________________________________________
screen-users mailing list
[email-masked]
http://lists.gnu.org/mailman/listinfo/screen-users

---

From: Peder Stray <[email-masked]>
Date: Mon, 18 Aug 2008 11:33:42 +0200 (CEST)

On Mon, 18 Aug 2008, Aaron Davies wrote:

> '\e]2;foo^G'), but when i try from a second-level nested screen, nothing 
> happens.
>
> i'm running putty-cyg on windows as my terminal, with cygwin zsh running 
> locally, running cygwin screen, ssh'ing into linux boxes, running bash 
> and screen remotely.

I use the following in my screenrc:

hardstatus on
hardstatus string "[%?%h%:%t%?]"

and use the normal \e]0;foo\a in my promt, which result in a plain foo in 
a normal xterm, and [foo] if inside screen, [[foo]] if inside a dual 
screen and so on.

-- 
   Peder Stray