Subject: Question on compiling screen on Solaris 10

From: "Yi, William CSC" <[email-masked]>
Date: Fri, 19 Sep 2008 13:53:42 -0400

Hi;

When I compile screen I got this message, do you have any idea what it
is?

gcc -c -I. -I/opt/screen-4.0.3    -g -O2 misc.c
misc.c: In function `xsetenv':
misc.c:619: error: too few arguments to function `setenv'
*** Error code 1
make: Fatal error: Command failed for target `misc.o'

William P. Yi (Bill)
Email: [email-masked] / [email-masked]

_______________________________________________
screen-users mailing list
[email-masked]
http://lists.gnu.org/mailman/listinfo/screen-users

---

From: Micah Cowan <[email-masked]>
Date: Sun, 21 Sep 2008 11:51:29 -0700

Yi, William CSC wrote:
> Hi;
> 
> When I compile screen I got this message, do you have any idea what it is?
> 

Yes; this has been fixed in the current sources, which you should be
able to compile. Follow the instructions at
https://savannah.gnu.org/git/?group=screen (you'll need to have Git
installed).

- --
Micah J. Cowan
Programmer, musician, typesetting enthusiast, gamer.
GNU Maintainer: wget, screen, teseq
http://micah.cowan.name/