Subject: Screen Issues

From: Clint Priest <[email-masked]>
Date: Wed, 29 Oct 2008 22:56:52 -0500

I'm having some difficult in getting screen to do what I'm looking for.  
What I want to do is to setup a screen config which will launch two 
windows, in the top window it would be the output from 'svn commit' and 
the bottom would be the output from 'svn diff | vim -R -'.  I've got 
most of it working but the problem I'm running into is that when the 
'svn commit' is complete I want it to automatically 'quit' the screen 
session. 

Here's the screenrc file I have setup for it:

---------------------------------------------
split
screen bash -c "svn commit || bash"
eval "resize 10"
focus
screen
exec ... /bin/bash -c "sudo svn diff | vim -R -"
focus
---------------------------------------------

I've tried numerous ways of getting the 'quit' to work automatically but 
have been unable to find a way to do it...

1) Is there any way to get 'quit' to work from the bash command line?
2) Is there any way to 'stuff' a keyboard command after the 'svn commit' 
ends?  I could then bind a key to quit and do it that way.

Thanks

_______________________________________________
screen-users mailing list
[email-masked]
http://lists.gnu.org/mailman/listinfo/screen-users

---

From: Robin Lee Powell <[email-masked]>
Date: Wed, 29 Oct 2008 22:20:51 -0700

> 1) Is there any way to get 'quit' to work from the bash command

Have it kill the parent process, which should be the screen session.

-Robin

-- 
They say:  "The first AIs will be built by the military as weapons."
And I'm thinking:  "Does it even occur to you to try for something
other than the default outcome?" -- http://shorl.com/tydruhedufogre
http://www.digitalkingdom.org/~rlpowell/ *** http://www.lojban.org/

---

From: Micah Cowan <[email-masked]>
Date: Wed, 29 Oct 2008 22:33:42 -0700

> Have it kill the parent process, which should be the screen session.

'screen -X quit' should also do the trick.

- --
Micah J. Cowan
Programmer, musician, typesetting enthusiast, gamer.
GNU Maintainer: wget, screen, teseq
http://micah.cowan.name/

---

From: Clint Priest <[email-masked]>
Date: Thu, 30 Oct 2008 08:55:22 -0500

That did it, thanks!

Micah Cowan wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Robin Lee Powell wrote:

1) Is there any way to get 'quit' to work from the bash command
line?

- --
Micah J. Cowan
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJCUc27M8hyUobTrERAg9FAJ9x4LHTl9mTyzkyKAYYdQQll9k8FgCeLGux
5eCEfHZJXFxSZV7sMVm7Yz4=
=oLjp